PDA

View Full Version : Chrome WebRTC leaking IP when using VPN



Arthursi
07-06-2015,
Hi

The add on WebRTC Block for chrome is not longer working.
Does anybody know how to disable WebRTC on Chrome in any other way?

I switched to the latest Chrome 43 beta version, hoping that I could disable it on chrome://flags.
Unfortunately that option is still grayed out, only available for Chrome android platform.

ArthurSt
07-07-2015,
I use WebRTC Block (https://chrome.google.com/webstore/detail/webrtc-block/nphkkbaidamjmhfanlpblblcadhfbkdm) on Iron (a Chrome based browser) and it works perfect !
You can test WebRTC leaks here (https://www.cyberghostvpn.com/en_us/rtctest).

OTT

ArtmurEn
07-07-2015,
Thanks OTT

I didn't know that. I'll give it a try.
Just downloaded Slimjet browser that allow WebRTC feature to be disabled on the security setting.
The reviews of this browser seems quite positive.

Regards,


VS

Arthursr
07-07-2015,
O.T.T., on 09 May 2015 - 3:45 PM, said:http://www.bleepingcomputer.com/forums/public/style_images/master/snapback.png (http://www.bleepingcomputer.com/forums/index.php?app=forums&module=forums&section=findpost&pid=3701805)

I use WebRTC Block (https://chrome.google.com/webstore/detail/webrtc-block/nphkkbaidamjmhfanlpblblcadhfbkdm) on Iron (a Chrome based browser) and it works perfect !
You can test WebRTC leaks here (https://www.cyberghostvpn.com/en_us/rtctest).

OTT

OTT

WebRTC Block on Iron, it still shows my IP. Checked with IPLEAK.

Slimjet WebRTC enable/disable feature works like a charms. Not quite sure I can get used to this browser though. So many features http://www.bleepingcomputer.com/forums/public/style_emoticons/default/scratchhead.gif

Thanks all the same.

http://www.bleepingcomputer.com/forums/public/style_emoticons/default/thumbup2.gif

Arthurvuse
07-08-2015,
Strange, no leaks here on Iron... tested on different sites.
I'm using Iron portable v41.0.2200.0
I see 2 different internal IP's (VPN and real) which doesn't mather and 1 external IP, that of my VPN...
If a try WebRTC it doesn't work.

Do you surf in Incognito mode ? In that case make sure WebRTC Block is allowed to run !
Check "Allow in Incognito mode" on the "chrome://extensions/" page.

I tested Slimjet in the past and it is a very good and fast browser with indeed "to many" functions : Video downloader, Facebook integration, File upload... which I could not shut down permanently, after each update they were turned on again.
That was the reason for me to not use it further !

OTT