View Full Version : Receiving 'Your Connection is not Private' message....

When trying to access some websites I receive a privacy error message saying 'Your Connection is not Private'. This is happening on Google and a similar message occurs on Comodo Dragon when I try to sign into the same website (in this case AOL mail).

This does not happen on the 3 laptops in the house (using windows 7).

Windows XP Home, SP 3 (yes I know it's old and not supported but cannot afford new system right now)
Dell Dimension DIM3000
Intel Celeron CPU 2.40G

Verizon Fios modem/router - hardwired

Google up to date
Comodo Dragon up to date

Time Clock/Date correct

Using Microsoft Security Essentials with Windows Firewall (have also tried disabling Firewall and still cannot access site).

Thank you.


The message means you can't get a secure SSL connection. Since you are using Chrome, try connecting in Incognito mode. If you can connect that way, one of your browser extensions is interfering with the connection. Try removing add-ons you don't need or use. Click on the menu icon in the upper right and select New incognito window, or press Ctrl-Shift-N with the browser open.

If that doesn't work, the SSL certificates on your computer may be out of date. Because Chrome uses the same certificates as Internet Explorer. make sure your Windows Updates and Microsoft product updates are up to date.

Doesn't work in incognito and have no browser extensions. XP up to date (as much as it can be) with SP3.

Tried Internet Explorer and can't get in that way either

Cleaned out cache, browser history, cookies, temp internet folder, even reset router....still cannot get in on this system.

Yep, Firefox is the answer. http://www.bleepingcomputer.com/forums/public/style_emoticons/default/icon_bananas.gif Eventually will get rid of this dinosaur, just can't right now.

Thanks for your help.

I had the exact same problem!!!
This fixed it:

open network and sharing center
On the left side- click on:
change advanced sharing settings.
click on home or work.
go through and check "turn off" for the first three questions.
turn on password.
Your computer connection was wide open!!!!