PDA

View Full Version : Problem setting program defaults



AnastasyaCab
07-21-2015,
I am having this weird problem where I can't set the program default for .ppt files as Powerpoint.

I have 64-bit Windows 7 and 32-bit Microsoft Office, which I just installed recently to replace the 64 bit version because the latter didn't work with Mendeley Desktop's automatic bibliography function.

For some reason, .ppt files are not automatically opened by Powerpoint. When I double click a .ppt file, I get a message asking me to select a default program. I first tried using POWERPNT.EXE, under Microsoft Office in Program Files (x86), but for some reason that opened up Adobe Acrobat. WTF!? Next I tried entering the same path that comes up for the Powerpoint icon when I type Powerpoint in at the start menu. This caused some weird program entitled "Microsoft Office Component" instead of "Microsoft Office Powerpoint" to appear in the programs menu that I get when selecting program defaults. I set it as the default and then tried double clicking a .ppt file - this yielded the bizarre error "<filename> is not a valid Win32 application". So I guess I did something wrong setting the default. I went back to the "choose default program" menu and tried navigating to POWERPNT.EXE again, but now selecting it does nothing at all - it just keeps displaying the same "Microsoft Office Component" icon and I keep getting the same error when I try to open the file. I went to the "set program defaults" under the control panel and found that the default for everything except .ppt (e.g. .pptx, .pps, etc.) are all set for "Microsoft Powerpoint". But I can't figure out for the life of me how to get .ppt to have the same setting. Help would be much appreciated!

Andersen
07-22-2015,
What version of Office are you using and did you uninstall the 64-bit version before you installed the 32-bit one?

I only ask because people have had difficulties in uninstalling Office 2010.

Probably a long shot, but can you try restoring to a restore point before you installed Office 64-bit?

AndersenOt
07-22-2015,
Thanks for your reply!

It's Office 2010 and I did uninstall the 64 bit one first, which was also 2010. I didn't encounter any problems while doing so.

I've never restored to a restore point before ... does that mean restore my whole hard drive to an earlier state? Sounds like overkill if so, but maybe I don't understand what it means.

AndreaEi
07-23-2015,
I am using Win7 Home Premium 64-bit.
I have MS Office Home and Student 2007.

1. If you have Open With in your right click context menu.....
Right click at your ppt > Open With > select Microsoft Office PowerPoint > put a checkmark at " always use the selected program to open this kind of file > OK

2. Start > Default Programs > Associate a file type or protocol with a program > under Name, scroll down to ppt > look across, under Current Default, it should say Microsoft Office Powerpoint ......
if it does not say that > top right > Change Program > select Microsoft Office PowerPoint > OK

How to add Open With to your right click Context Menu
Open With Context Menu Item - Add or Remove (http://www.sevenforums.com/tutorials/52833-open-context-menu-item-add-remove.html)

AndreaEl
07-24-2015,
Hi t-4-2, thanks for your reply but I already tried both of the things you said and they didn't work, hence my post. Sorry if this wasn't clear.

http://www.sevenforums.com/images/misc/q.gif Quote: Originally Posted by t-4-2 http://css.designermediacdn.com/images/styles/window7/buttons/firstnew.gif (http://www.sevenforums.com/microsoft-office/167891-problem-setting-program-defaults-post1435258.html#post1435258)
1. If you have Open With in your right click context menu.....
Right click at your ppt > Open With > select Microsoft Office PowerPoint > put a checkmark at " always use the selected program to open this kind of file > OK


My problem is: HOW to "select Microsoft Office PowerPoint" after clicking "Open With"? It doesn't appear as an option. When I click "Browse" I get taken to the full hard drive directory. From there, problems arise as mentioned in my original post.

Quote:
2. Start > Default Programs > Associate a file type or protocol with a program > under Name, scroll down to ppt > look across, under Current Default, it should say Microsoft Office Powerpoint ......
if it does not say that > top right > Change Program > select Microsoft Office PowerPoint > OK


It doesn't say Microsoft Office Powerpoint. When I try to Change Program, I run into the same problem just described.