PDA

View Full Version : Go to open files shortcut troubles



angelicaul69
09-18-2015,
Quickly navigating between open files using the keyboard is important to me. The "Go To Anything" seems promising, but I'm having some troubles with it.
If I assign Alt+Q to Commando: Focus on Go To Anything and then press Alt+Q the field is populated with a JS error:
http://forum.komodoide.com/uploads/default/original/2X/e/e6627c2614a86087a093950336cee448c343c8be.png
If I assign Alt+Q to Commando: Go to anything the choose pops up in an odd location often:
http://forum.komodoide.com/uploads/default/original/2X/d/de7287eaf03f079bbc8a14a44496110c3221c54c.png
This popup also remembers where I was before, which seems okay, except when I press Esc to exit it goes up a level instead. Can I configure Esc to always completely dismiss it instead. Having to press it once or twice makes it annoying to get back to where I was.
A way to configure this to just show a list of open files would also be nice. The full go to anything feature is fine, but I'd really like a key to just show the open files as well.

Angelababytage
09-19-2015,
Hi, you've found a bug in "Commando: Focus on Go To Anything". I've logged the bug here:https://github.com/Komodo/KomodoEdit/issues/1727
As for "Commando: Go to anything", I get the popup showing up in the correct place, so I cannot comment on that. However, if you'd like to dismiss it with one keystroke, just type Alt+Q again. At least that dismisses it for me.
If you go to your keybinding preferences and search for "commando", you'll find commands to immediately access one of the scopes. I think you're interested in the "open files" scope. That should make things easier for you.

AndyEagele
09-20-2015,
Note that most of the Commando key binds act as toggles, so pressing them again would hide Commando.

AngeblRids
09-21-2015,
Okay, Alt+Q again works. Open Files shortcut is nicer. Two problems remain:


it still opens in a wacky location (that location is consistent, random the first time, but keeps showing up there each time I press Alt+Q again)
the list is outdated when I open it. If I open/close a bunch of files they do not appear in the list.
However, if I start typing, then both the position corrects itself, and the list updates itself. Pressing arrow up/down does not do this however.

andros69
09-23-2015,
Given the description I think the two issues are probably the same -- some piece of init code is not being run when activated via the shortcut.