PDA

View Full Version : Setting The Correct PHP version In komodo IDE 9



beerbit
10-09-2015,
I get the error "Error determining PHP version" when I try to set my PHP exceutable in my Komodo 9 IDE to which I am a new comer-
Menu path :Edit-Languages-PHP.
Under Default PHP Interpreter (the first Path box), I entered the following :
c:\wamp\bin\apache2.4.9\php.ini
Under Use this ecexutable( the second path box), I am not sure what I should enter.
So I entered c:\wamp\bin\apache2.4.9\php.ini again.
komodo is not happy and is giving me the above error.
I am new to komodo IDE and I am stuck.
Any help, please ?
Moses Mirundi-UK.

BelindaRots
10-11-2015,
Default PHP Interpreter - path to your php.exe or php5.exe (not sure how it's called in Windows)
Use this executable - leave it empty if you don't use Composer in PHP.
The third path box is path to your php.ini, you can specify it or leave it empty. (in case if it will be empty - Komodo will uses its own php.ini)

Benniemr
10-13-2015,
As I said, you need to set the first pathbox to your php.exe path.
In your case, I guess it's C:\Wamp\bin\php\php<version>\php.exe
You can open cmd and run where php to determine the php.exe file and the path to it.

benyahyaalfort
10-14-2015,
I could not get php.exe but I got php5ts.dll but the error message is still there.
The path in the first box is now now
c:\wamp\bin\apache\apache2.4.9\bin\php5ts.dll
The path in the second box is now empty.
The path in the third box is now
c:\wamp\bin\apache\apache2.4.9\bin\php.ini
I still get the eroor, "Error determining PHP version"
So, the problem continues and I still need help/support to fix it.
Regards
Moses Mirundi