PDA

View Full Version : cannot set password never expires (server 2012)



bgegqztqfb
06-04-2015,
I have a stand alone server 2012.
I login as local Administrator.
I see the popup message:your password is expired in 1 day,you must change your password.
I open local security policy in server manager
I go to the object account policies->password policy->max password age
The age is set to 42 and is greyed out.I want to set it to 0 but I cannot change the value.

How can i change it to 0?

bgbhyyqqvo
06-05-2015,
I've also tried gpedit.msc and tried to change the max password but all the security settings in computer configuration are greyed out and cannot be changed.

bggjpbyavu
06-07-2015,
Go into Active Directory Users and Computers, find the user account you want to set to password never expires, open the Account tab, and under account options, select Password never expires.

Or, open the PowerShell for Active Directory module, and enter Set-ADUser -UserPrincipalName <enter the username here> -PasswordNeverExpires $true

BGSete
06-07-2015,
As I said it's a stand alone server and no domain controller.
I can log in a domain but I have no Active Directory Users and Computers in tools of server manager and if I had that I would not find there the local administrator account of the stand alone server.
In active directory is the domain administrator(of a external domain controller) I think.

bhghichhun
06-07-2015,
If your options in the local security policy snap-in are greyed out, they have been or or being overriden by domain group policies.

Was this server ever joined to a domain at some point?

If not, check to see if User Account Control is disabled, and enable it.

bhoineehpo
06-08-2015,
This server is a virtual machine.I did not install it.I copied the image from someone.So I didn't know if this server was ever joined to a domain.
I've checked user acount control and the registery value EnableLUA was set to 1 so its enabled.
In control panel the account control setting is set to notify