Results 1 to 5 of 5
  1. #1

    Installing CA certs in Ubuntu 17.10... nothing seems to work

    I have tried everything I can to get my local domain CA cert, as well as other missing CAs, like the Comodo roots and intermediates, installed on my laptop running Ubuntu 17.10.

    The page below has been helpful in understanding where everything is installed, but for whatever reason, nothing is updated. There are many other things I've tried over the past few weeks (when I have time), but I don't remember them all now.

    What is the "correct" procedure, and is there any other reason why these certs wouldn't install?

    https://askubuntu.com/questions/6458...r-command-line

  2. #2
    Did you ever get into an ncurses gui after the last step to make sure your new certifcates were added/trusted?

    Also: What software are you trying to get to trust these certs? Not all software uses the system certificate store.. For example, citrix receiver needs some special handling...

  3. #3
    Funny you should ask.... yes, Citrix Receiver is one, but even Chrome isn't trusting them. I have not run ncurses. Not even familiar with it, but googling it now.

  4. #4
    I've run dpkg-reconfigure ca-certifciates, as well as every other command I can get my hands on.

    I'm not sure if ncurses is the colored text-mode window (ie: typical install menu for Unix/DOS type installers), but I've seen that as well.... the one where you select (with asterisks) each cert you want to install. I believe it then cats them into a single file with all the CA hashes inside. I have verified the cipher text of my internal CA is in that file, so I just don't get why Chrome isn't seeing it.

  5. #5
    Ok... that would make a LOT of sense. I assumed it was like Windows, where Chrome/Chromium can read the Windows cert store, but Firefox can't. In Firefox, you need to load all your certs in the browser.

    Ironically, it looks like Chromium uses the Firefox cert store in a Linux OS. That's insane, but it's something to try. Thanks for the help. I'll report back when I have a chance to mess with it... hopefully tonight.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •